[ TROUBLE REPORT ]


Microsoft Windows XP Professional  + Microsoft Virtual PC 2004

Microsoft Virtual PC 2004 のネットワークが利用できない【未解決】

2005/08/02 Tomohiro Kumagai

□ ネットワークへ接続できなくなってみる

EZ-NET レポート: Microsoft Virtual PC 2004 を使ってみる にて紹介した Virtual PC 2004 ですけど、快適に使えていたのですけど、あるとき急にネットワークの動作が不自然な感じになってしまったのでした。

 

ホストコンピュータとして Microsoft Windows XP Professional を使用していて、ネットワークには ELECOM 社の LD-WL54G/PCI という無線 LAN アダプタを利用していました。

その環境で長いこと問題なく利用できていたのですけど、あるとき Virtual PC を 2 台立ち上げて Windows XP と Slackware Linux 9.0 を起動させていたところ、ホストコンピュータの LAN アダプタがいったん通信を絶ったと思ったら、Virtual PC 上の Windows XP ネットワークアダプタが切断された状態となってしまったのでした。

そのまま Virtual PC を再起動してみると、Windows のほうは問題なく治ったようだったのですけど、それ以来、Linux の方のサービスへホストコンピュータから上手く接続できなくなってしまったのでした。

 

なぜか Virtual PC からは外部ネットワークへ接続する事はできました。

でも外部からはというと、PING はホストコンピュータからは通らないし、でも必ずしも全てではなくて、ほんの稀に 3 パケットくらい応答がもらえることもあったり…。ホストから Linux へ SSH 接続してみようとすると、Linux 側で SYN_RECEIVE パケットを受け取ったまま、次のステップへ進んでくれなかったり…。

最初は Linux の方だけかと思っていたのですけど、Windows の方もそんな感じでした。

 

□ ネットワークアダプタを調整してみる

ネットワークがおかしいのだから、とりあえずネットワーク周りの環境チェックです。

とはいえ別のコンピュータからホストコンピュータへは問題なく接続できるので、問題となっているのは Virtual PC 2004 周りのネットワーク環境ということになるのでしょうか…。そんなことを思いながら、とりあえず Virtual PC 2004 のネットワーク割り当てが正しいかどうか確認してみましたけど、ちゃんと無線 LAN アダプタが割り当てられていました。

ネットワークアダプタの修復処理を行ったり、無線 LAN に割り当てられている "Virtual Machine Network Services" を無効にしてみたりもしてみたのですけど、それで何かが改善されるということはありませんでした。

 

システムがおかしくなってしまったことも考えて、とりあえず無線 LAN 自体のデバイスドライバも更新してみることにしました。

ELECOM 社のサイトから LD WL54G/PCI の最新ドライバをダウンロードしてインストールしなおしてみました。最新のドライバとは言っても、既に導入済みのバージョンでしたけど。ともあれそれでも改善される事はありませんでした。

 

□ Virtual PC 2004 を再インストールしてみる

ネットワーク環境には Virtual PC 2004 以外ではなんら不調は見受けられなかったので、もしかすると何かの拍子に Virtual PC 2004 がおかしくなってしまったのかもしれないです…。

なのでとりあえず、再インストールを行ってみることにしました。

 

【コントロールパネル】 から 【プログラムの追加と削除】 を起動して、まずは一覧の中から "Microsoft Virtual PC 2004 Service Pack 1" を選択して削除処理を行います。 削除終了後には特に何も言われませんでしたけど、念のため PC を再起動しておきました。

そして Microsoft Virtual PC 2004 のインストール作業を行います。

Microsoft Virtual PC 2004 の CD-ROM から、インストーラを起動して手順どおりに作業を進めて行きます。そしてインストールが完了したら、続いて Microsoft 社のサイトから入手した "Microsoft Virtual PC 2004 Service Pack 1" をインストールします。

 

インストールの時にネットワークアダプタが一時無効になるのですけど、その度に無線 LAN への再接続になにやら失敗してしまうような感じだったので…、"修復" すれば直るのですけど、インストール後に念のため再起動しておくことにしました。

そして再起動後、Virtual PC 2004 を動かしてみましたけど…、状況は変わる事はありませんでした。

 

□ その他の心当たりを探してみる…

再インストールでもなんともならないとすると、あと思い当たるものといったら Windows ファイアーウォールとか Symantec AntiVirus の Auto-Protect くらいでしょうか…。

ただしどれも以前から使っていたものであってそのときは問題なかったですし、実際にそれらを無効にしてみても、なんら変わる事はありませんでした。

 

他には、仮想 PC それぞれの LAN アダプタに割り当てられていた MAC アドレスを参照してみると、2 台共に同じ MAC アドレスが割り当てられているのも気になったので、VMC ファイルを開いて片方を少し調整したりもしてみましたけど、それでも改善されることはありませんでした。

それでも MAC アドレスは、各仮想 PC 毎に異なる MAC アドレスが本来は割り当てられるような感じがしますので、重なってしまっている場合は少し調整しておいたほうが良いような感じはします。

 

なんにせよ、ネットワークの不調の問題はなんだかよく判らない状況です…。

今は少し時間がないので、また今度、調整してみようと思います。


 

カスタム検索

copyright © Tomohiro Kumagai @ EasyStyle G.K.
contact me: please from mail-form page.