[ TROUBLE REPORT ]


Microsoft Windows XP Professional

ワイヤレスネットワークが利用できなくなってみる

2005/05/26 Tomohiro Kumagai

□ ワイヤレスネットワーク環境

Microsoft 社の Windows XP Professional を、無線 LAN を用いてネットワークへ参加させていました。

ワイヤレスネットワーク環境としては、ELECOM 社の LD-WL54G/AP というアクセスポイントを利用して、同じく ELECOM 社の LD-WL54G/PCI という PCI 接続型の無線 LAN アダプタを用いて接続している感じでした。

IP アドレスはアクセスポイントからではなく、別に用意してあった DHCP サーバから取得するような設定となっています。

 

□ ネットワークに繋がらなくなってみる

その環境でなんら問題なく利用できていたのですけど、ある日 Apple 社の Mac mini を購入して、それを AirMac Extreme にて無線 LAN へ参加させたときに、今回の問題が発生してしまったのでした。

そのときのお話は EZ-NET レポート: Mac mini + AirMac を使ってみる にても触れてあるのですけど、このとき AirMac では WAP 暗号化のキー番号を変更することが出来ないらしくて、アクセスポイントのキー番号設定を 1 番に設定しなおしたんですよね。

そうして当然のように Windows XP Professional の方のキー番号も 1 番に設定しなおして、当然のようにネットワークに接続できていたのですけど…、次の日に PC を起動してみたところ、ネットワークに上手く参加できていないという問題が発生してしまったのでした。

 

IP アドレスは正常に割り当てられているのですけど、何故かネットワークを利用できなくなってしまいました。

同一ネットワーク内への通信さえも出来なくて、でもネットワークアダプタ自体は認識されているみたいだし、ワイヤレスネットワークの状態も正常に接続が確立して利用可能となっている…。

とりあえずワイヤレスネットワークの 「修復」 を行ってみたところ、正常にネットワークが利用できるようになりました。でも次回起動時にはまた同じような症状が発生してしまって、手動で 「復旧」 を行わないといけなくて困った感じです。

初回に接続できないとなると、ただ面倒ならのみならず、Windows ドメインへのログオンも上手く行きませんし、起動にもやや時間がかかってしまうので、元通りになるよう復旧を試みてみました。

 

□ ワイヤレスネットワークを復旧する

ワイヤレスネットワークの設定を調整しなおしてみる (失敗)

とりあえずもう一度、ワイヤレスネットワーク自体へは正常に接続できていることを確認しつつ…。ワイヤレスネットワークの状態を表示して、目的の SSID に正常に接続され、それなりに経過時間が経っていることを確認しました。また、シグナルの強さも問題ない感じです。

変更したのはアクセスポイントと、各 PC のキー番号のみ。そして他の PC は再起動してもなんら問題なく再接続できるので、どうやら問題はこの Windows XP のみにありそうです。なのでまずは、ワイヤレスネットワークの設定を再設定しなおしてみることにしました。

 

キー番号を別のものに変更して、改めて正しい 1 番に直してみましたけど、それでは改善されずでした。

なのでいったん SSID を一覧から削除して、改めて登録しなおしてみようとしたら…、なんといわゆる青画面が一瞬表示されて再起動となってしまいました。この PC はすごく安定していて青画面などもはや見ていない感じだっただけに、びっくりでした。

そのまま再起動をして、また SSID 等を登録してみましたけど、登録こそ出来たもののやはり同じ現象が残りました。

 

セーフモードで起動してみる (効果なし)

青画面が出たこともあり、セーフモードで Windows XP を起動してみました。

起動ロゴが出る直前に <F8> キーを押してセーフモードへ突入させます。何かおかしいときにセーフモード起動してみると治ってしまうこともあるので、そんなことに期待してやってみたのですけど、相変わらずでした。

 

DHCP 周りを調べてみる (異常はあり)

無線 LAN のコネクション自体は、WEP 暗号化自体も含めて確立しているような感じがするので、なにか DHCP 周りでおかしくなっているのかなと、そのあたりを調べてみることにしました。

【復旧】 ボタンを押せば正常に IP アドレスの更新処理を通過することから、問題なさそうな感じはしたのですけど、とりあえず ipconfig コマンドを使って、次のようにいったん解放 (release) し、再び取得 (renew) してみます。

ipconfig /release

ipconfig /renew

するとしばらく待たされた後で、DHCP サーバへ接続できなかったというようなエラーが返ってきました。

 

何かの都合で DHCP サーバが読み取れず、リースが切れたか何かでまずはこの PC に問題が発生したのかとか考えてみたのですけど、同じことを正常に動作中の PC にても行ってみたところ、待たされることなく IP の再取得が出来てしまったりしたので、どうやらそれもなんだか違うようでした。

念のためアクセスポイントと DHCP サーバとを再起動してみましたけど、その程度ではなんら進展はありませんでした。

 

ドライバを入れなおしてみる (解決)

他に考えられる方法として、とりあえず LD-WL54G/PCI のドライバをインストールしなおすくらいしか思い当たらなかったので、それを行ってみることにしました。

ELECOM 社のサイトより LD-WL54G/PCI のドライバをダウンロードして、インストールしてみます。

 

【コントロールパネル】 の 【ネットワーク】 から ”ワイヤレスネットワーク接続” を表示して、【全般】 タブにある 【構成】 ボタンをクリックして、"Air@Hawk LD-WL54AG/PCI Wireless PCI Adapter" のプロパティを表示します。

そしてその 【ドライバ】 タグを選択して、ドライバの再インストールを行います。

 

まずは 「ドライバの更新」 ボタンを押して、ハードウェアの更新ウィザードが起動したら、「一覧または特定の場所からインストールする」 を選択して、ドライバの更新作業を行ってみます。

最初は 「次の場所で最適のドライバを検索する」 を選んで、自動検出先として先ほどダウンロードしたドライバを指定してみたのですけど、適合性のあるドライバが見つからなかったとのことで、インストールしなおす事はで来ませんでした。

なので 「検索しないで、インストールするドライバを選択する」 を選んで進んでみると、こちらではとりあえず、ドライバのインストールをしなおす事はで来ました。

 

けれど結局は同じ症状のままだったので、ここは一度、ドライバを削除してしまうことにしました。

先ほどのダイアログにて今度は 「削除」 ボタンを押し、ドライバのアンインストールを行いました。そして Windows を再起動してみると、自動的に LD-WL54AG/PCI が認識されてドライバのインストールウィザードが起動したので、改めてダウンロードしたドライバを指定してみます。

すると、適合するドライバが見つかり、インストール作業は正常に終了となりました。

 

ドライバのインストール終了後、ワイヤレス LAN の設定で再び同じ SSID に接続するように設定してみたところ、今度は何事もなかったのようにアクセスポイントへ接続され、IP アドレスも正常に取得し、問題なくそのままネットワークへ参加することが出来るようになりました。

再起動しても起動直後から正常に接続できますし、ためしに ipconfig を使って IP アドレスの再取得を行ってみましたけど、どれもまったく問題なしでした。

 

キー番号を変更しただけなので、どういう都合でだかはよく判りませんけど、とりあえずドライバ周りがおかしくなってしまっていたみたいですね。ともあれ正常に戻ってホッとしました。

 


 

カスタム検索

copyright © Tomohiro Kumagai @ EasyStyle G.K.
contact me: please from mail-form page.